Billingbooth

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Service Outage
Resolved·Full outage

The issue has now been resolved.

Mon, Mar 30, 2026, 08:35 PM
(2 months ago)
·
Affected components
Mar 30, 2026, 07:27 PM
07:54 PM
Billingbooth One
Website
Updates

Resolved

The issue has now been resolved.

Mon, Mar 30, 2026, 08:35 PM

Monitoring

All our services appear to be working normally. We continue to monitor the situation.

Mon, Mar 30, 2026, 07:54 PM(40 minutes earlier)

Identified

We have identified the problem as a backbone network routing issue with our host in one of their data centres. We await an update from our host, but all our monitoring services show a normal service resumed for now.

Mon, Mar 30, 2026, 07:44 PM

Investigating

We are seeing services restoring from our monitoring service, and access appears possible. We are still investigating the cause of this issue.

Mon, Mar 30, 2026, 07:40 PM

Investigating

We have had reports of a service outage across all our Billingbooth One services. We are investigating.

Mon, Mar 30, 2026, 07:27 PM(12 minutes earlier)